Web: https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2022-40640

Sept. 15, 2022, 4:15 p.m. |

National Vulnerability Database nist.gov

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Ansys SpaceClaim 2022 R1. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of X_B files. The issue results from the lack of proper validation of user-supplied data, which can result in a read before the start of an allocated data structure. An attacker can leverage this …

cve

Cybersecurity Engineer

@ Apercen Partners LLC | Folsom, CA

IDM Sr. Security Developer

@ The Ohio State University | Columbus, OH, United States

IT Security Engineer

@ Stylitics | New York City

Information Security Engineer

@ VDA Labs | Remote

Information Security Analyst

@ Metropolitan Transportation Commission | San Francisco, CA

Director of Security Operations, CISO office

@ Okcoin | San Jose, California, United States

Systems Security Engineer

@ Synctera | Canada or US Remote

Cyberark Senior Consultant I | Remote, Canada

@ Optiv | Toronto, ON

Privacy & Cybersecurity Counsel

@ Brightspeed | Charlotte, NC, United States

Sr/Staff Threat Researcher

@ SecurityScorecard | Remote (US/Canada)

Consultant SOC / CERT H/F

@ Hifield | Sèvres, France

SOC Analyst

@ Starling Bank | Southampton, England, United Kingdom